Skip navigation

CISCO : routage inter-VLAN

le routage inter-VLAN via un router

Il existe plusieurs méthode de routage inter-VLAN, la plus commune étant la la méthode router-on-a-stick.

inter-vlan-routing

Configuration des VLAN sur le switch

Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/12
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#interface gigabitEthernet 0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#no shutdown

Configuration des interfaces virtuelles du routeur

Pour faire communiquer PC1 avec PC2 dans cette configuration, il faut créer 2 interfaces virtuel sur le routeur Router.

Router(config)#interface gigabitEthernet 0/0.10
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 172.16.10.254 255.255.255.0
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 172.16.20.254 255.255.255.0
Router(config-subif)#exit
Router(config)#interface gigabitEthernet 0/0
Router(config-if)#no shutdown

by | March 30, 2016 | No Comments | Système


Laisser un commentaire

Votre email ne sera pas publié. Required fields are marked*