Skip navigation

CISCO : protocole de routage RIP v2

Configurer le protocole de routage RIP v2

RIP pour Routing Information Protocol est un protocole de routage IP à vecteur de distances. Le nombre de sauts est limité à 15. Au-delà, les paquets sont supprimés. Dans sa version 2, RIP prendre en compte les réseaux sans classe.

Contexte

Considérant le shéma suivant, en vert le réseau 172.16.0.0/24, en jaune le réseau 10.0.0.0/24 et en bleu le réseau 200.0.0.0/30 permettant aux router de communiquer entre eux.
Les interfaces des clients (ici PC0 à PC3) ont des IP statiques.
Pour plus de clareté, les router seront nommés « router-south » et « router-north ».

pt-dynamic-routing-protocole

Configuration des interfaces

Configuration du router-south.

Router>enable
Router#configure terminal
Router(config)#hostname router-south
router-south(config)#interface gigabitEthernet 0/0
router-south(config-if)#ip address 10.0.0.254 255.255.255.0
router-south(config-if)#no shutdown
router-south(config-if)#exit
router-south(config)#interface serial 0/0/0
router-south(config-if)#ip address 200.0.0.1 255.255.255.252
router-south(config-if)#clock rate 64000
router-south(config-if)#no shutdown
router-south(config-if)#end 

Configuration du router-north.

Router>enable
Router#configure terminal
Router(config)#hostname router-south
router-north(config)#interface gigabitEthernet 0/0
router-north(config-if)#ip address 172.16.0.254 255.255.255.0
router-north(config-if)#no shutdown
router-north(config-if)#exit
router-north(config)#interface serial 0/0/0
router-north(config-if)#ip address 200.0.0.2 255.255.255.252
router-north(config-if)#no shutdown
router-north(config-if)#end 

Configuration de RIP v2

Sur le router-south.

router-south(config)#router rip
router-south(config-router)#version 2
router-south(config-router)#network 10.0.0.0
router-south(config-router)#network 200.0.0.0
router-south(config-router)#no auto-summary 
router-south(config-router)#end 
router-north(config)#router rip
router-north(config-router)#version 2
router-north(config-router)#network 172.16.0.0
router-north(config-router)#network 200.0.0.0
router-north(config-router)#no auto-summary 
router-north(config-router)#end 

by | February 14, 2015 | No Comments | CISCO | Tags : protocole RIP routage routage dynamique


Laisser un commentaire

Votre email ne sera pas publié. Required fields are marked*