Skip navigation

CISCO : protocole de routage OSPF

Configurer le protocole de routage OSPF sur un router

OSPF pour “Open Shortest Path First” est un protocole de routage libre à état de liens.

Contexte

Considérant le shéma suivant, en vert le réseau 172.16.0.0/24, en jaune le réseau 10.0.0.0/24 et en bleu le réseau 200.0.0.0/30 permettant aux router de communiquer entre eux.
Les interfaces des clients (ici PC0 à PC3) ont des IP statiques.
Pour plus de clareté, les router seront nommés « router-south » et « router-north ».

pt-dynamic-routing-protocole

Configuration des interfaces

Configuration du router-south.

Router>enable
Router#configure terminal
Router(config)#hostname router-south
router-south(config)#interface gigabitEthernet 0/0
router-south(config-if)#ip address 10.0.0.254 255.255.255.0
router-south(config-if)#no shutdown
router-south(config-if)#exit
router-south(config)#interface serial 0/0/0
router-south(config-if)#ip address 200.0.0.1 255.255.255.252
router-south(config-if)#clock rate 64000
router-south(config-if)#no shutdown
router-south(config-if)#end 

Configuration du router-north.

Router>enable
Router#configure terminal
Router(config)#hostname router-south
router-north(config)#interface gigabitEthernet 0/0
router-north(config-if)#ip address 172.16.0.254 255.255.255.0
router-north(config-if)#no shutdown
router-north(config-if)#exit
router-north(config)#interface serial 0/0/1
router-north(config-if)#ip address 200.0.0.2 255.255.255.252
router-north(config-if)#no shutdown
router-north(config-if)#end 

Configuration de OSPF

Sur le router-south.

router-south(config)#router ospf 1
router-south(config-router)#network 10.0.0.0 0.0.0.255 area 0
router-south(config-router)#network 200.0.0.0 0.0.0.3 area 0
router-south(config-router)#no auto-summary 
router-south(config-router)#end 

: sur la première ligne, le 1 représente le process_ip. Le process_id est un identifiant utilisé en interne pour ce processus de routage. Il peut être n’importe quel entier positif. Cet ID ne doit pas nécessairement correspondre à l’ID d’un autre périphérique du réseau; il est attribué pour un usage interne uniquement. Il est possible d’utiliser au maximum deux processus.
Sur la seconde ligne, il faut renseigner le réseau et la wildcard de ce réseau. La wildcard s’obtient en soustrayant un masque de sous-réseau /32 au masque de sous-réseau actuellement utilisé. Dans le cas présent pour le réseau 200.0.0.0/30 on obtient :

 255.255.255.255
-255.255.255.252
----------------
  0 . 0 . 0 . 3 

: Enfin pour l’area il s’agit de la « zone » de réseau touché par cette configuration, comme l’illustre le schéma suivant.

ospf-area

Sur le router-north.

router-south(config)#router ospf1
router-north(config-router)#network 172.16.0.0 0.0.0.255 area 0
router-north(config-router)#network 200.0.0.0 0.0.0.3 area 0
router-north(config-router)#no auto-summary 
router-north(config-router)#end 

Une fois la route le réseau 200.0.0.0 correspondant, dans ce cas, à l’interface de sortie renseignée, il devrait y avoir une sortie semblable à celle-ci.

sortie

%OSPF-5-ADJCHG: Process 1, Nbr 200.0.0.1 on Serial0/0/1 from LOADING to FULL, Loading Done

by | February 14, 2015 | No Comments | CISCO | Tags : protocole de routage protocole OSPF routage


Laisser un commentaire

Votre email ne sera pas publié. Required fields are marked*