Skip navigation

CISCO : protocole de routage EIGRP

Configurer le protocole de routage EIGRP sur un router

EIGRP pour “Enhanced Interior Gateway Routing Protocol” est un protocole de routage propriétaire Cisco. EIGRP est une évolution de IGRP, ils sont tous deux des protocoles de routage à vecteur de distance. EIGRP est optimisé pour minimiser l’instabilité de routage due aussi bien au changement de topologie qu’à l’utilisation de la bande passante et la puissance du routeur.
L’une des optimisations de ce protocole est basée sur l’algorhytme DUAL (Diffusing Update Algorithm) qui garantit l’absence de boucle. Ce, en évitant les « sauts à l’infini » car les paquets ont une TTL de 224.

Contexte

Considérant le shéma suivant, en vert le réseau 172.16.0.0/24, en jaune le réseau 10.0.0.0/24 et en bleu le réseau 200.0.0.0/30 permettant aux router de communiquer entre eux.
Les interfaces des clients (ici PC0 à PC3) ont des IP statiques.
Pour plus de clareté, les router seront nommés « router-south » et « router-north ».

pt-dynamic-routing-protocole

Configuration des interfaces

Configuration du router-south.

Router>enable
Router#configure terminal
Router(config)#hostname router-south
router-south(config)#interface gigabitEthernet 0/0
router-south(config-if)#ip address 10.0.0.254 255.255.255.0
router-south(config-if)#no shutdown
router-south(config-if)#exit
router-south(config)#interface serial 0/0/0
router-south(config-if)#ip address 200.0.0.1 255.255.255.252
router-south(config-if)#clock rate 64000
router-south(config-if)#no shutdown
router-south(config-if)#end 

Configuration du router-north.

Router>enable
Router#configure terminal
Router(config)#hostname router-south
router-north(config)#interface gigabitEthernet 0/0
router-north(config-if)#ip address 172.16.0.254 255.255.255.0
router-north(config-if)#no shutdown
router-north(config-if)#exit
router-north(config)#interface serial 0/0/1
router-north(config-if)#ip address 200.0.0.2 255.255.255.252
router-north(config-if)#no shutdown
router-north(config-if)#end 

Configuration de EIGRP

Sur le router-south.

router-south(config)#router eigrp 1
router-south(config-router)#network 10.0.0.0
router-south(config-router)#network 200.0.0.0
router-south(config-router)#no auto-summary 
router-south(config-router)#end 

: sur la premier commande router eigrp 1 le 1 représente le numéro du système autonome.

Sur le router-north.

router-south(config)#router eigrp 1
router-north(config-router)#network 172.16.0.0
router-north(config-router)#network 200.0.0.0
router-north(config-router)#no auto-summary 
router-north(config-router)#end 

Une fois la route le réseau 200.0.0.0 correspondant, dans ce cas, à l’interface de sortie renseignée, il devrait y avoir une sortie semblable à celle-ci.

sortie

L-5-NBRCHANGE: IP-EIGRP 1: Neighbor 200.0.0.1 (Serial0/0/1) is up: new adjacency
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 200.0.0.2 (Serial0/0/0) is resync: graceful restart

by | February 14, 2015 | No Comments | CISCO | Tags : protocole de routage protocole EIGRP routage routage dynamique


Laisser un commentaire

Votre email ne sera pas publié. Required fields are marked*